Live-Migration of Instance With Config Drive Fails
Problem
An instance which has config_drive set to True fails to live-migrate.
The destination hypervisor reports the following error in /var/log/pf9/ostackhost.log.
ERROR oslo_messaging.rpc.server [...] Exception during message handling: InvalidSharedStorage: 0f15c8ad-bbeb-473b-9aa9-3bf38cc952d5 is not on shared storage: Shared storage live-migration requires either shared storage or boot-from-volume with no local disks.Environment
Platform9 Managed OpenStack - v3.6 - v3.11
Nova
Libvirt
Cause
Due to a limitation with the corresponding Libvirt version, a configuration drive using the ISO-9660 format cannot be live-migrated.
Resolution
To migrate the instance, you will need to perform a cold (non-live) migration, or snapshot and re-create it.
Workaround
As per the guidance outlined in the configuration drive format, you may be successful in leveraging the legacy VFAT format for future instances which require to be live-migrated with a config-drive attached.
Additional Information
PreviousGlance Selects Wrong Endpoint
NextInstance(s) Stuck in "MIGRATING" State After Abort Migration Action
Last updated
