Failed To Create ISCSI Target For Cinder Volume
Problem
The Hypervisor requesting to attach volume fails to create ISCSI target to the Cinder host
The below messages could be seen in the cinder logs for the mentioned volume on the host where the volume resides
less /var/log/pf9/cindervolume-base.log | grep -i 55dbd6ac-1842-4c0a-bcde-d07e2c5e39fd
2022-05-04 09:24:25.996 INFO cinder.volume.flows.manager.create_volume [req-1d2f6876-f8a2-45e8-9b0b-d47aab8764b0 None devops-sla] Volume 55dbd6ac-1842-4c0a-bcde-d07e2c5e39fd: being created as raw with specification: {'status': 'creating', 'volume_name': 'volume-55dbd6ac-1842-4c0a-bcde-d07e2c5e39fd', 'volume_size': 1}
2022-05-04 09:24:28.520 INFO cinder.volume.flows.manager.create_volume [req-1d2f6876-f8a2-45e8-9b0b-d47aab8764b0 None devops-sla] Volume volume-55dbd6ac-1842-4c0a-bcde-d07e2c5e39fd (55dbd6ac-1842-4c0a-bcde-d07e2c5e39fd): created successfully
2022-05-04 09:25:45.173 WARNING cinder.volume.targets.tgt [req-1f13bf94-8a3b-417f-ab36-b7b12bdb00e2 None devops-sla] Failed to create iscsi target for Volume ID: volume-55dbd6ac-1842-4c0a-bcde-d07e2c5e39fd. It could be caused by problem with concurrency. Also please ensure your tgtd config file contains 'include /opt/pf9/pf9-cindervolume-base/state/volumes/*'
2022-05-04 09:25:47.251 WARNING cinder.volume.targets.tgt [req-1f13bf94-8a3b-417f-ab36-b7b12bdb00e2 None devops-sla] Failed to create iscsi target for Volume ID: volume-55dbd6ac-1842-4c0a-bcde-d07e2c5e39fd. It could be caused by problem with concurrency. Also please ensure your tgtd config file contains 'include /opt/pf9/pf9-cindervolume-base/state/volumes/*'Environment
Platform9 Managed OpenStack
Cause
<The reason for the problem, if known.>
Resolution
cat /opt/pf9/etc/pf9-cindervolume-base/conf.d/cinder_overrides.conf files.
[lvm-backend]
target_protocol = iscsi
lvm_type = default
volume_backend_name = <Node>Additional Information
< Links to supporting documentation, caveats, or other helpful background information that’s not strictly a problem, environment, cause, or resolution. >
PreviousInstance Failed To Start When Multipath Volume is Attached
NextInstance Task State Stuck in Deleting
Last updated
