Unable to Start Instance With Error "Cannot allocate memory"
Problem
Starting an instance from a SHUTDOWN state results in the following error being observed in the pf9-ostackhost log located under /var/log/pf9 directory.
2021-10-11 01:59:23.636 ERROR nova.virt.libvirt.driver [...] [instance: 7e008ee7-3dc1-4a02-b9a4-587d2f9ea591] Failed to start libvirt guest: libvirt.libvirtError:internal error: qemu unexpectedly closed the monitor: 2021-10-11T05:59:23.408060Z qemu-kvm: cannot set up guest memory 'pc.ram': Cannot allocate memoryEnvironment
Platform9 Managed OpenStack - All versions
Nova
Libvirt
Cause
The instance fails to start because the libvirt process is not able to allocate the required memory being requested by the instance.
Resolution
Try migrating a few running instances to a different host.
If there is no hosts available to accommodate the running VMs, provision additional physical memory on the host.
PreviousResize or Migrate Operations Failing With HTTP 409 Error "Service is unavailable at this time"
NextUnable to Remove Fixed IP Address
Last updated
