Cinder Services Down After Host Upgrade
Problem
Cinder services are down after the host upgrade.
Unable to start the Cinder services. Below errors are observed in /var/log/pf9/cindervolume-base.log
WARNING cinder.volume.manager [req-xxxx None None] Update driver status failed: (config name other-backend) is uninitialized.WARNING cinder.utils [req-xx None xxxx ] Volume driver (TintriDriver 2.2.0.1) is currently unsupported and may be removed in the next release of OpenStack. Use at your own risk.Environment
Platform9 Managed OpenStack - v4.3
Cinder
Tintri Backend driver.
Cause
Tintri driver is marked as unsupported in the OpenStack Stein release and will be removed from the OpenStack Train release.
Resolution
Follow the below steps to resolve the issue with OpenStack Stein Release:
Add the configuration in the Cinder configuration file.
Restart the service Cinder service on the affected Cinder nodes.
Additional Information
Refer to the below links for respective OpenStack release notes.
PreviousBFV Instance Fails to Migrate: "Driver initialize connection failed (error: PureHTTPError status code 400)
NextEnabling Non-zero Value for "live_migration_progress_timeout" in Nova Results Live Migration Failure
Last updated
