"Unable to obtain pidfile" Error While Starting Libvirtd Service
Problem
libvirtd service failed to start with below error reported in /var/log/messages.
kdt-dpckvm01 libvirtd[404581]: libvirt version: 1.3.1, package: 1ubuntu10.24 (Marc Deslauriers [marc.deslauriers@ubuntu.com] Wed, 23 May 2018 13:29:29 -0400)kdt-dpckvm01 libvirtd[404581]: hostname: kdt-dpckvm01kdt-dpckvm01 libvirtd[404578]: /usr/sbin/libvirtd: error: Unable to obtain pidfile. Check /var/log/messages or run without --daemon for more info.kdt-dpckvm01 libvirtd[404581]: Failed to acquire pid file '/var/run/libvirtd.pid': Resource temporarily unavailablekdt-dpckvm01 systemd[1]: libvirt-bin.service: Main process exited, code=exited, status=1/FAILUREkdt-dpckvm01 systemd[1]: libvirt-bin.service: Unit entered failed state.kdt-dpckvm01 systemd[1]: libvirt-bin.service: Failed with result 'exit-code'.kdt-dpckvm01 systemd[1]: libvirt-bin.service: Service hold-off time over, scheduling restart.Environment
Platform9 Managed OpenStack - v3.6.0 and Higher
Cause
The libvirtd service fails to start as the /var/run/libvirtd.pid file is not accessible.
Resolution
Remove PID file on the affected KVM host.
$ rm -rf /var/run/libvirtd.pidRestart the libvirtd service on the KVM host.
$ systemctl restart libvirtPreviousHost Reporting in "Error Authorized State" Due to Missing Physical Network Config Label
NextCreate Soft Affinity/Anti-Affinity Server Groups
Last updated
