Unable to Authenticate With OpenStack CLI
Problem
Using the same credentials which successfully authenticate a user in the Clarity UI, running OpenStack CLI commands after sourcing the credentials file fails with the following error:
$ openstack server list
The request you have made requires authentication. (HTTP 401) (Request-ID: req-b4861fe6-0ad5-47ae-b321-d0aad26ff18b)Environment
Platform9 Managed OpenStack - All Versions
OpenStack CLI (unified or project specific)
Cause
Special characters in the OS_PASSWORD environment variable set using the instruction available in the Platform9 document, Installing OpenStack CLI Clients, must be 'escaped' to prevent the shell from interpreting them in an unintended manner.
Resolution
List the OpenStack environment variables, and note any which do not return exactly as intended.
$ env | grep OS_Identify the first character for each variable which is not returned in the output of the command in Step #1 and insert a backslash () into the variable's value just before the identified character.
Source the edited rc file.
Verify commands are now returning expected output as would be seen in the UI using the installed OpenStack CLI.
Last updated
