For the complete documentation index, see llms.txt. This page is also available as Markdown.

Instance Booted via UEFI Unable to be Deleted

Problem

Instances launched with UEFI boot enabled will not delete with error "Requested operation is not valid: cannot delete inactive domain with nvram".

Environment

  • Platform9 Managed OpenStack - v3.6.0 and Higher

  • Nova

  • OVMF

  • Libvirt/Virsh

Cause

This behavior is related to an upstream bug - LP#1567807. Nova creates a libvirt instance with [loader] and [nvram] elements, and libvirt refuses to implicitly delete the nvram file.

Resolution

  1. Obtain the UUID and Host of the instance you are trying to delete. For example, via Clarity UI.

Screen_Shot_2018-10-29_at_9.27.38_AM.png
Screen_Shot_2018-10-29_at_9.27.38_AM.png
  1. SSH into the host where the instance is launched.

  2. Verify if the instance is running on the hypervisor.

  1. Undefine the domain using virsh.

Note: The --nvram flag has to be explicitly defined, else un-define will fail with the same error as initially described. 5. The instance may now be deleted successfully.

Additional Information

Last updated