Unable to Attach Floating IP to Instance: "External Network Not Reachable from Subnet

Problem

  • A floating IP is unable to be attached to an instance.

  • The following error is observed in Clarity UI when attempting to attach the floating IP.

Environment

  • Platform9 Managed OpenStack - All Versions

  • Neutron

Causes

  • No router has been created and associated with the subnet.

  • Router associated with subnet, but isn't connected to external network.

  • Router isn't connected to internal subnet, but has an external gateway.

Resolution

No Router Has Been Created

  1. For guidance with creating a router, refer to Create Router in our networking guide.

Subnet Not Associated with Router

  1. In Clarity UI, navigate to "Networks" > "Routers".

  2. Click on the desired router.

    • Note: Ensure you are scoped to the appropriate tenant to be able to view the router.

  3. Navigate to the "Interfaces" tab.

  4. Click "+ Create New Interface".

  5. Select the desired subnet.

  6. Click "Add Interface".

Router Has No External Gateway

  1. In Clarity UI, navigate to "Networks" > "Routers".

  2. Click on the radio button for the desired router.

  3. Click "Edit Router".

Screen_Shot_2019-12-18_at_9.03.06_AM.png
Screen_Shot_2019-12-18_at_9.03.06_AM.png
  1. Select an external network from the "Set External Network" dropdown.

Screen_Shot_2019-12-18_at_9.03.28_AM.png
Screen_Shot_2019-12-18_at_9.03.28_AM.png
  1. Click "Update Router".

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