For the complete documentation index, see llms.txt. This page is also available as Markdown.

Live Migration Failed, Multipathd Service Not Running on Destination Host

Problem

Instance live migration fails with below error in ostackhost.log of source host.

ERROR nova.compute.manager [-] [instance: "instance-id"] Pre live migration failed at "destination-host-uuid": RemoteError: Remote error: ProcessExecutionError Unexpected error while running command.Command: multipathd show statusExit code: 1...TRACE nova.compute.manager [instance: "instance-id"] Stderr: u'ux_socket_connect: Connection refused<br>'

Environment

  • Platform9 Managed OpenStack - All Versions

  • multipathd

  • pf9-ostackhost

Cause

  • The pf9-ostackhos t service on the source and the destination host is configured to use the multipath connection for volumes.

# less /opt/pf9/etc/nova/conf.d/nova_override.conf..volume_use_multipath = True..
  • Once the live migration is initiated, a pre-live migration check is performed to confirm if the destination host is running the multipathd service.

  • If this pre-live migration check fails, the below command on the destination host will give the error mentioned in the problem section on source host.

$ multipathd show status
  • On the destination host, we can observe the error message with the live-migration request ID as below.

ERROR os_brick.initiator.linuxscsi [req-xxxxxxxxxxx user@domain service] multipathd is not running: exit code 1: ProcessExecutionError: Unexpected error while running command.
  • Check the status of multipathd service on the destination host.

  • This issue is most often observed if the multipathd service is not running on the destination host.

Resolution

  • Check multipath configuration in / etc/multipath.conf file on destination host.

  • If the configuration is correct, start the multipathd service if not running on the destination host.

Last updated