SSO Users Have "Email" Field on Support Form

Problem

A superfluous "Email" field is presented to SSO users when attempting to submit a support request in the Clarity UI.

Screen_Shot_2020-11-25_at_11.42.42_AM.png
Screen_Shot_2020-11-25_at_11.42.42_AM.png

Environment

  • Platform9 OpenStack - All Versions

  • Clarity UI

Cause

A bug was introduced that prevents this field from being hidden as it is automatically populated on submission.

Resolution

A bug report has been created and the proper resolution is currently being investigated. We will update this article with more information as it becomes available.

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