Failed to Setup Container for group 57: No available IOMMU Models
Problem
Instance in an error state as libvirtd failed to setup container for group 57 as there was no IOMMU module configured on the host.
Failed to start libvirt guest: libvirtError: internal error: qemu unexpectedly closed the monitor: 2020-06-26T23:19:48.842902Z qemu-system-x86_64: -device vfio-pci,host=83:00.0,id=hostdev0,bus=pci.0,addr=0x5: vfio error: 0000:83:00.0: failed to setup container for group 57: No available IOMMU modelsEnvironment
Platform9 Managed OpenStack - All Versions
Libvirtd
Cause
vfio_iommu_type1 module isn't loaded.
pf9@host:~$ lsmod | grep vfio_iommu_type1pf9@host:~$Resolution
Load the Module using the followingcommand.
pf9@host:~$ modprobe module_namepf9@host:~$ lsmod | grep vfio_iommu_type1vfio_iommu_type1 20480 0vfio 28672 2 vfio_iommu_type1,vfio_pciInstance seen to be in the running state after making the change.
Additional Information
PreviousUnable to Create Volume From Image
NextLive Migration Failed, Multipathd Service Not Running on Destination Host
Last updated
