Block Storage Host Reports "Unable to locate Target IQN"
Problem
A Block Storage (Cinder) host is logging the following (in /var/log/messages ) related to being unable to locate a target IQN.
Jan 5 14:34:16 host-1 kernel: Unable to locate Target IQN: iqn.2010-10.org.openstack:volume-80332ca1-617c-434b-b909-e83c4c42a6d3 in Storage Node
Jan 5 14:34:16 host-1 kernel: iSCSI Login negotiation failed.Environment
Platform9 Managed OpenStack - All Versions
Block Storage (Cinder)
Cause
The volume referenced (by UUID) no longer exists, i.e. it has been deleted, but, a hypervisor did not log out its iSCSI connection (likely due to a missed RPC calls, which can result from flaky networking).
Resolution
List iSCSI connections for a host.
# iscsiadm -m session -P 3If a session is present (for the referenced volume UUID), logout the iSCSI connection, passing the target name with
-Tand the IP:port of the iSCSI portal (typically the Block Storage host – the IP is shown in the previous output) with-p.
# iscsiadm -m node -T iqn.2010-10.org.openstack:volume-80332ca1-617c-434b-b909-e83c4c42a6d3 -p 172.30.0.194:3260 --logoutPreviousOutbound Network Connectivity Failing for Instances Connected to a Virtual Router
NextVolume Attachment and Detachment Fails With Error "Flushing test_lv--test_vg failed: oslo_concurrency.processutils.ProcessExecutionError: [Errno 2] No such file or directory: 'multipath'"
Last updated
