QEMU Image Lock Fail to Start VMs After Host Crashes
Problem
Migrated or Evacuated VMs fail to start on destination host when the source host crashes. The following error is observed in log /var/log/pf9/ostackhost.log.
569 ERROR nova.virt.libvirt.driver [req-7638759c-10a6-40c5-86f9-4bda4b2dfb82 masakari services] [instance: 65c55b81-9078-44b4-bb07-95dc5adeadba] Failed to start libvirt guest: internal error: qemu unexpectedly closed the monitor: 2019-10-28T00:39:09.301445Z qemu-kvm: -drive file=/mnt/nfs/instances/65c55b81-9078-44b4-bb07-95dc5adeadba/disk,format=qcow2,if=none,id=drive-virtio-disk0,cache=none: Failed to get "write" lockEnvironment
Platform9 Managed OpenStack - v3.6.0 and Higher
NFSv3
QEMU
Cause
Limitation in NFSv3.
Solution
Wait for the crashed host to come back online.
Once the crashed host is online, reboot the VMs which failed to get a write-lock.
Additional Information
PreviousHost Convergence Failure Due to Inability to Acquire DPKG Frontend Lock
NextHeat Stack Creation Fails With Error "No images matching
Last updated
