Adding Host Using Pf9-express Fails
Problem
Adding a new node using pf9-express fails with the below error:
The error was: DiscoveryFailure: Could not find versioned identity endpoints when attempting to authenticate. Please check that your auth_url is correct. Not Found (HTTP 404)Environment
Platform9 Managed OpenStack - v5.0 and Higher
Pf9-express
Cause
The pf9-express utility is using auth_url pointing to the Keystone v2.0 endpoint, whereas the Keystone endpoint is upgraded to the v3.
Resolution
Modify the
auth_urland try to add the host again using pf9-express:
- name: Set OS_AUTH fact set_fact: os_auth: auth_url: "{{du_url}}/keystone/v3" username: "{{os_username}}" password: "{{os_password}}" project_name: "{{os_tenant}}"Additional Information
Starting with the Platform9 v5.0 release, the v2.0 Keystone endpoint has been removed.
PreviousInstance Failing to Boot, Entering Emergency Mode: "Timed out waiting for device"
NextHosts With pf9-glance Role Failing To Converge With Error "inconsistent use of tabs and spaces in indentation
Last updated
