VM migration fails with error 'Unable to create allocation for 'DISK_GB' on resource provider'

Problem

  • Migration of a VM instance fails with below error:

2022-10-04 10:52:32.471 5924 WARNING nova.scheduler.client.report [req-150eabb9-xxxx-xxxx-994d-b80a5787ab35 b8935406ffda4a6ab1316777dbda1bba a317fe3586ed474e9605c3464487be97 - default default] Unable to post allocations for consumer 369f7d20-0e97-49a1-9b93-ea2325803ddf (409 {"errors": [{"status": 409, "title": "Conflict", "detail": "There was a conflict when trying to complete your request.<br> Unable to allocate inventory: Unable to create allocation for 'DISK_GB' on resource provider 'f9c9c94e-xxxx-xxxx-96bb-c8257362f2a5'. The requested amount would exceed the capacity.  ", "code": "placement.undefined_code", "request_id": "req-b1a81585-e977-4b34-aa17-78c8e7fff49b"}]})

Environment

  • Platform9 Managed OpenStack - v5.4.0 and Higher

Cause

  • The disk space was overcommitted on the source host and nova-scheduler does care about the disk space being over-committed on the source.

Resolution

  • Edit the /opt/pf9/etc/nova/conf.d/nova_override.conf file on the source host.

  • Increase "disk___allocation___ratio" (to a value something like 1.5).

  • Restart pf9-ostackhost service:

# systemctl restart pf9-ostackhost
# systemctl status pf9-ostackhost

Additional Information

Last updated