Glance Image Create Fails With Error "Request Entity Too Large
Problem
The Glance image creation fails when user tries to create an image from the Management Plane. The error observed is as follows.
# openstack image create UBUNTU1804_ISO --file /home/chinmay/ubuntu-18.04.3-live-server-amd64.iso --disk-format iso --container-format bare413 Request Entity Too Large: nginx/1.14.1 (HTTP 413)Environment
Platform9 Managed OpenStack - All Versions
Glance
Cause
The admin endpoint is not configured to create images. Because the creation attempt was done on the Management Plane, the admin RC file is sourced, you cannot create images.
Resolution
Download the RC file from the UI for your user.
Source the RC file and create the image.
PreviousOutbound Connectivity Failing for Instances on Tenant Network
NextInstance Reboot Failure as Libvirt Failed to Terminate qemu-kvm Zombie Process
Last updated
