Instance Creation Failing: "Could not open backing file"
Problem
Instance creation is failing with the following error.
Could not open backing file: Could not open '/opt/pf9/data/instances/_base/[UUID]': Permission deniedAppArmor is installed/enabled on the hypervisor.
Environment
Platform9 Managed OpenStack - All Versions
Nova
Libvirt
AppArmor
Cause
The default AppArmor profile for Libvirt does not include access to the instance storage path; thus, the I/O request is blocked.
Resolution
Append the following lines to the AppArmor configuration at
/etc/apparmor.d/usr.lib.libvirt.virt-aa-helper.
Parse the updated rules.
Additional Information
Previouspf9-ostackhost Service Failing With Error: "Connection to libvirt failed"
NextNo Connectivity to Docker Containers Within Instance
Last updated
