VM Build Fails due to Service 'org.freedesktop.machine1' Failing to Activate and Timed out
Problem
VM build fails with the below error logs in pf9-ostackhost logs.
2024-09-10 01:11:04.779 ERROR nova.compute.manager [req-38f8dc99-4712-4cf8-9077-56d772768e1b ..] [instance: <instance-uuid>] Failed to build and run instance: libvirt.libvirtError: Failed to activate service 'org.freedesktop.machine1': timed out
2024-09-10 01:11:04.779 TRACE nova.compute.manager [instance: <instance-uuid>] Traceback (most recent call last):
...
2024-09-10 01:11:04.779 TRACE nova.compute.manager [instance: <instance-uuid>] libvirt.libvirtError: Failed to activate service 'org.freedesktop.machine1': timed out
2024-09-10 01:11:04.779 TRACE nova.compute.manager [instance: <instance-uuid>]
2024-09-10 01:11:07.024 INFO nova.compute.manager [req-38f8dc99-4712-4cf8-9077-56d772768e1b ..] [instance: <instance-uuid>] Took 1.98 seconds to deallocate network for instance.
2024-09-10 01:11:07.653 INFO nova.scheduler.client.report [req-38f8dc99-4712-4cf8-9077-56d772768e1b ..] Deleted allocation for instance <instance-uuid>Environment
Platform9 Managed OpenStack - v4.0 and Higher
Cause
Systemd-machined is a system service that keeps track of locally running virtual machines and containers. However, sometimes it has been observed that this service does not show errors but still libvirt fails to activate the service and build VM.
Resolution
Restart the systemd-machined service. Verify once the service is stable.
Additional Information
The underlying Linux host system service may experience virtualisation issues, but restarting the service typically resolves the problem.
PreviousVM Build Fails as Network Fails to Get due to Allocated
NextVM Live-migration Fails due to Duplicate Port Bindings
Last updated
