Bootable Volume Creation Fails With Error "key signature_verified exists for volume
Problem
The volume creation fails when the volume is being created using an image. The following error is observed in the cindervolumebase.log located under /var/log/pf9/ directory.
ERROR cinder.volume.flows.manager.create_volume [...] Failed updating volume 446e9e1e-bb79-4a72-bd07-9cb6d492916a metadata using the provided image f136a750-0398-4529-bf23-d01d1582acbe metadata: GlanceMetadataExists: Glance metadata cannot be updated, key signature_verified exists for volume id 446e9e1e-bb79-4a72-bd07-9cb6d492916aEnvironment
Platform9 Managed OpenStack - All Versions
Cinder
Cause
The error is observed because Glance signature verification is enabled in Cinder configuration.
Resolution
Login to the Cinder host and add the following property to the cinder_override.conf file under the DEFAULT stanza.
verify_glance_signatures = disabledRestart the pf9-cindervolume-base service using the following command.
service pf9-cindervolume-base restartPreviousHeat Stack Creation Fails With Error "No images matching
NextCinder Fails to Create a Boot From Volume Instance When Multipath is Enabled on the Storage Array
Last updated
