Unable to Delete Volume From HPE 3PAR With Error "VolumeIsBusy: resource in use

Problem

  • OpenStack volume fails to delete even though the volume is in a detached and available state.
  • The following error is observed in Cinder logs ( /var/log/pf9/cinder-volume-base.log) on the block storage host.
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Environment

  • Platform9 Managed OpenStack - All Versions
  • Cinder
  • HPE 3PAR

Cause

  • The volume fails to delete because of a stale export present in the 3PAR storage.
  • The stale export could be caused because of a failed live migration attempt on the instance using this volume.
  • When a volume is in a detached and available state, there should be no export present in the 3PAR UI.

Resolution

  1. Log into the 3PAR management console and search for the volume using comments as the filter since Platform9 saves the volume UUID in the comments section of the volume.
  2. Once you successfully locate the volume, check the entries in the 'Exports' section of the volume properties.

Note: The UUID mentioned in the 'Exports' section indicates the host UUID on which the instance using the volume used to reside.

  1. Create a test instance.
  2. Migrate the test instance to the host on which the volume already has an export.
  3. Attach the volume to be deleted to this test instance.
  4. Once the volume is attached successfully, detach it from the test instance.
  5. Confirm that the 'Exports' section in the 3PAR UI is empty.
  6. Refresh the Platform9 UI to confirm that the volume is now detached and in an available state.
  7. Delete the volume using the Platform9 UI.

Note: If the volume fails to detach from the test instance, try deleting the test instance.

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