Instance Missing on Hypervisor

Problem

  • Instance goes into ERROR state after failing to start.
  • Running openstack server show [uuid] command shows an instance fault such as the following.
Copy

Environment

  • Platform9 Managed OpenStack - All Versions
  • Nova

Causes

  1. Instance failed to migrate.
  2. Disk is full on hypervisor.

Resolution

Instance Failed to Migrate

  1. Determine on which host the instance resides on.
Copy
  1. Check if the instance is running on the host obtained from the previous output.
Copy
  1. Confirm that the instance XML file still exists on the hypervisor.
Copy
  1. If the XML file resides on the host, redefine the instance using virsh.
Copy
  1. Reset the state of the instance.
Copy

Disk Full

  1. Identify which partition is full.
Copy
  1. Inspect which folder(s) or file(s) are consuming the most amount of disk space.
Copy
  1. At your discretion, optionally backup and/or remove or truncate the offending large files which are consuming the most space.

Note: If you are uncertain if a particular file may be removed or truncated belonging to PF9, please contact Support.

Type to search, ESC to discard
Type to search, ESC to discard
Type to search, ESC to discard