Unable to Assign Fixed IP While Creating Port

Problem

When trying to assign a fixed IP to a port using Clarity UI, an error saying "Invalid or out-of-range IP address" is observed.

Environment

  • Platform9 Managed OpenStack - v3.6.0 and Higher
  • Neutron

Cause

  • The allocation pool mentioned within the subnet is entered incorrectly.

Resolution

  1. Login to the Clarity UI and navigate to the "Networks" tab.
  2. Click on the Network name in which the port is to be created.
  3. Navigate to the "Subnets" section.
  4. Check the allocation pool corresponding to the subnet in which the port is to be created.
  5. If the allocation range covers 2 subnets as shown below, split the allocation pool into two. One for each subnet.
Copy
  1. After updating the allocation pool, it should look like this.
Copy
Type to search, ESC to discard
Type to search, ESC to discard
Type to search, ESC to discard