Unable to Assign Fixed IP While Creating Port
Problem
When trying to assign a fixed IP to a port using Clarity UI, an error saying "Invalid or out-of-range IP address" is observed.
Environment
- Platform9 Managed OpenStack - v3.6.0 and Higher
- Neutron
Cause
- The allocation pool mentioned within the subnet is entered incorrectly.
Resolution
- Login to the Clarity UI and navigate to the "Networks" tab.
- Click on the Network name in which the port is to be created.
- Navigate to the "Subnets" section.
- Check the allocation pool corresponding to the subnet in which the port is to be created.
- If the allocation range covers 2 subnets as shown below, split the allocation pool into two. One for each subnet.
- After updating the allocation pool, it should look like this.
Was this page helpful?