Unable to Deauthorize Host - Package(s) Fail to be Erased (Apt)

Problem

  • Deauthorizing a host or hypervisor fails (such as via the UI).
  • In /var/log/pf9/hostagent.log on the host which fails to be deauthorized, it is observed that one or more PF9 packages fail to be removed or erased.
Copy
  • Additionally, connection failures such as the following are also observed – indicating one or more repositories are unreachable.
Copy

Environment

  • Platform9 Managed OpenStack - All Versions
  • Ubuntu
  • Apt

Cause

As part of the package erasure process, the apt-cache is updated prior to marking a package for removal – to be purged from the system. As such, this requires that the configured Apt repositories be reachable via TCP port(s) 80/443. A firewall or network misconfiguration may be preventing communication to these external repositories.

Resolution

  1. Allow communication to either or both of the aforementioned ports – 80 and 443 – dependent on which protocol is used by the configured repositories. This may be accomplished in many different ways, including leveraging an HTTP(s) proxy or apt-proxy host within your internal infrastructure (especially if the hosts do not normally have outside connectivity, except to the Platform9 management plane via 443).
  2. Attempt the host de-authorization once more.
Type to search, ESC to discard
Type to search, ESC to discard
Type to search, ESC to discard