Service pf9-kube fails to start because of a corrupted sudoers file

Problem

The host is stuck in converging state, as service pf9-kube fails to start with the following errors seen in kube.log

Copy

Checking the sudo status for the pf9 group will give an error similar to

Copy

Environment

  • Platform9 Managed Kubernetes - All Versions

Cause

  • Syntax error or a typo in the sudoers file results in service pf9-kube not starting.

Resolution

  1. Login to the Node with the Root credentials.
  2. Use visudo to edit the sudoers file to resolve the error which is highlighted in the sudo groups pf9 output as shown above in the problem section.

Additional Information

  • If your Node was created without a default root account, refer to our article on how to login to rescue shell.
Type to search, ESC to discard
Type to search, ESC to discard
Type to search, ESC to discard