'K8s Node Status' Column not Populated after Hard Refresh in PF9 UI

Problem

When the UI loads for the first time or if we hard refresh the page, on the "Nodes" tab, the "K8s Node Status" column returns empty.

Environment

  • Platform9 Managed Kubernetes UI - 5.6.Z

Cause

  • The first refresh of the UI does not invoke the K8sAPI proxy call to get nodes from the K8s API server. It is invoked a few mins after a hard refresh.
  • This is the reason we do not see a status under the "K8s Node Status" column. The engineering team is working on a fix and the same is being tracked under UX-2696

Workaround

Manually click the 'Refresh' button in the UI which should load the status immediately.

Type to search, ESC to discard
Type to search, ESC to discard
Type to search, ESC to discard