Degraded LoadBalancer Ingress Endpoint Performance (AWS)
Problem
A Kubernetes LoadBalancer Ingress endpoint for a particular service is slow to respond (± ~3 seconds).
Environment
- Platform9 Managed Kubernetes - All Versions
- AWS Cloud Provider
- Flannel
Cause
Flannel is unable to contact etcd. A firewall appliance may be present within the VPC which is blocking the traffic, especially on Port 4001 which is required for etcd communication as per the Networking Prerequisites.
Resolution
- Whitelist the ports called out in the Networking Prerequisites, especially for etcd.
- Restart Flannel on the worker node(s).
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