Kubeconfig Cannot be Retrieved With Multi-Factor Authentication (MFA) Enabled
Problem
- In Clarity UI, under 'Infrastructure' tab, the kubeconfig cannot be retrieved for a cluster when multi-factor authentication (MFA) is enabled.

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Environment
- Platform9 Managed Kubernetes - All Versions
- Multi-Factor Authentication (MFA)
- Keystone
Cause
No field is exposed in the UI to allow for the MFA code to be entered.
Resolution
N/A - No fix is currently available for this issue. The current workarounds are listed below.
- MFA may be disabled for the user(s) who require the ability to download the kubeconfig from the UI, or a separate user will have to be created without MFA enabled for this action.
- The built-in CLI exposed within Clarity UI may be used to perform operations on the cluster in addition to retrieving the kubeconfig.

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Additional Information
For guidance on how to configure and disable MFA, please refer to Set Up Multi-Factor Authentication.
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