Kubernetes Dashboard Inaccessible After v4.3 Upgrade

Problem

An HTTP 404 failure is encountered when attempting to access the K8s Dashboard for any of the clusters post-management plane upgrade to Platform9 Managed Kubernetes v4.3.

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Environment

  • Platform9 Managed Kubernetes - v4.2-v4.3
  • Clarity UI

Cause

  • The kubernetes-dashboard deployment had to be updated as part of the overall upgrade to K8s 1.16 (corresponding to PMK v4.3).
  • As part of this, the namespace changed from kube-system to kubernetes-dashboard.
  • A mismatch will occur if attempting to access the dashboard prior to the cluster upgrade since the UI and all management plane components are upgraded separately from the clusters themselves and will attempt to access the dashboard via the legacy URL.

Resolution

Method 1:

  1. Upgrade the PMK cluster (to K8s 1.16, corresponding to the PMK v4.3 release).

Method 2:

  1. In Clarity UI, from any tab, click on "Try Our New UI" (bottom left).
TryNewUI.png

TryNewUI.png

  1. Sign in as prompted.
Screen_Shot_2020-08-12_at_4.22.38_PM.png

Screen_Shot_2020-08-12_at_4.22.38_PM.png

  1. Navigate to Infrastructure > Clusters.
  2. Click the "Dashboard" hyperlink for any listed cluster(s).
Screen_Shot_2020-08-12_at_4.24.12_PM.png

Screen_Shot_2020-08-12_at_4.24.12_PM.png

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