Cluster Upgrade Failure Due To Sunpike Services Being Down.
Problem
Sunpike log entries missing in the sunpike logs while sunpike services are down in the DU VM.
Environment
- Platform9 Edge Cloud - v5.3 and Higher.
Cause
- Sunpike service failure.
Resolution
- This is a known issue with the sunpike system services and Platform9 Engineering is working on the fix. Contact Platform9 Support to check the status of the bug.
Workaround
- Manually start the all the sunpike services in the DU VM before re-initiating the cluster upgrade.
# systemctl start sunpike-kine sunpike-kube-apiserver sunpike-kube-controllers sunpike-apiserver sunpike-conductor sunpike-controller-managerWas this page helpful?