Multiple Local Keystone User Authorisation Failed with "AssertionError: User is disabled" Error

Problem

  • Local users failing to authorise and below mentioned error was observed in the keystone logs during the time of issue.
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Environment

  • Platform9 Edge Cloud - v5.1 and Above

Cause

  • This issue has been observed after the Reboot or Migration activity of the Management Plane Host.
  • The exact cause of the issue is still unknown but it is suspected due to the mysql database corruption.
  • The similar issue can also be observed for qbert , resmgr and appbert local users which can result in authorisation failures for the respective components

Resolution

  • Check the value for last_active_at parameter in MySQL DB for the affected users and confirm that the date entry mentioned in there is very old.
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Check if the affected users are enabled or disabled using the command mentioned below.

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Check if the disable_user_account_days_inactive parameter is enabled in the keystone.conf file.

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Comment the disable_user_account_days_inactive parameter in the /etc/keystone/keystone.conf file and restart the keystone service.

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If the qbert , resmgr and appbert users are also affected due to this issue then restart the pf9-resmgr , pf9-qbert and pf9-appbert services on the management plane.

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This should help to resolve the authorisation issue with the respective user and service.

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