Unable to Create VM On Compute Host- Aggregate Sync Issue

Problem

When attempting to create a VM on a newly added compute node, the following error is observed in the UI or through the CLI:

UI
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Additionally, the nova-scheduler pod logs show the following message:

Management Plane
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The above message in logs indicate that the issue is the resource provider mapping for the new/existing compute node is incorrect

Environment

  • Platform9 Private Cloud Director - v2025.4 and Higher
  • Self Hosted Private Cloud Director Virtualization – v2025.4 and Higher
  • Component - Compute

Cause

This issue may occur due to host-aggregate synchronization problems. Specifically, the compute host may not be properly recognised by the Placement API as part of the aggregate, which leads to the scheduler being unable to locate valid hosts for allocation.

For SaaS users who do not have access to the DB, an alternative way to identify the affected host is to migrate an existing test VM to new or existing hosts.

For Self-Hosted PCD this can be validated using the below steps:

Validate if the resource mapping is completed by comparing the data of the existing nodes to the new node in the placement DB by following below steps

  1. Log into the database
Bash
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  1. Switch to the placement DB
Bash
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  1. Check the resource provider mapping is created in the tables resource_provider_aggregates and resource_providers. If the resource details are not mapped correctly, there will be a discrepancy observed with the created_at and updated_at timestamps in the below two tables with the timestamp when the node was onboarded.
SQL
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SQL
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In the above sample output, the updated_at timestamp (2025-06-05 17:23:20) in resource_providers table for id "144" is older than the created_at (2025-06-07 19:15:45) timestamp from the resource_provider_aggregates which highlights the discrepancy. In this case, host1.example.com is affected by this issue.

Resolution

The issue could be resolved by removing the problematic compute host from its host aggregate and re-adding it. This action triggers Nova to re-notify placement and successfully schedule VMs to the host.

Steps:

  1. List All Aggregates
Oenstack CLI
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  1. Inspect a Specific Aggregate and check if the problematic host is part of any aggregate:
Openstack CLI
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  1. Remove the Host from Aggregate
Openstack CLI
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  1. Add the Host Back to the Aggregate
Openstack CLI
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This action re-registers the host within the aggregate and updates Placement API visibility.

Additional Information

Ensure that the nova-compute service is running and registered:

Openstack CLI
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Check for any errors in the ostackhost log on the hosts:

Affected Host
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For Self-Hosted PCD users, check the below pod logs:

Pod log
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