VM Deployment Failed Due to Insufficient Storage

Problem

VM deployment using Ephemeral storage fails with "No valid host was found" on ostackhost logs, and "insufficient resources or a temporary occurrence as compute nodes start up" error in Nova-scheduler logs.

Nova-scheduler logs
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Environment

  • Self-Hosted Private Cloud Director Virtualization - v2025.4 and Higher
  • Self-Hosted Private Cloud Director Kubernetes - v2025.4 and Higher

Cause

VM deployment failed because the requested size surpassed the resource provider's max_unit allocation. Further details on [max_units] allocation.

Diagnostics

On underlying host:

  1. Get the VM disk storage path using command given below:
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  1. Check where the VM disk storage path is mounted.

The OpenStack placement API takes Disk dev mapper size into account when calculating the resource provider's max unit value.

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Here,

  • VM disk storage path is mounted on "/".
  • The OpenStack consider this 98 GB size while calculating the resource provider's max unit value.

OpenStack CLI:

  1. List down all available resource providers. These resource providers are responsible for allocating the CPU, Memory and Storage to the VMs.
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  1. Check for max_unit for Disk_GB on all resource providers listed above.

Any VM requesting an ephemeral storage disk above the max_unit value will fail with "insufficient resources or a temporary occurrence as compute nodes start up" error in the nova-scheduler logs.

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Here,

The DISK_GB for the resource provider is 97GB, a value determined by the VM's disk storage configured for the root (/) mount point.

Resolution

  1. Use image which has storage requirements less than the max_unit value from all available resource providers.
  2. It is recommended to use Cinder-backed volumes for VM deployments.

Validation

  1. How much storage is requested by the image used to deploy VM.
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  1. If these steps prove insufficient to resolve the issue, reach out to the Platform9 Support Team for additional assistance.
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