Unable to Add Host in Management Plane
Problem
- Unable to view host in Management Plane for authorization even after running the installer script successfully.
- On the affected host, check if it is able to communicate with the Management Plane on port 443.
- If the above command was successful check /etc/pf9/hostagent.conf for the cert_version followed by requesting the certificate using the same version.
- The above command will not return the certificate. This confirms that the host is unable to communicate with the Management Plane using the SNI broker version 4 for certificates.
Environment
- Platform9 Managed OpenStack - v3.6.0 and Higher
- Hostagent
Cause
The SNI broker-v4 endpoint is blocked in the firewall on the customer plane.
Resolution
Allow the broker-v4 endpoint communication through the customer firewall.
Workaround
- Run the below command to check if the affected host is able to request a certificate from the Management Plane using any other version.
- If the above command returns the certificate successfully, copy the certificates from one of the working hosts to the affected host.
- On the affected hosts, keep the backup of original /etc/pf9/certs directory and then replace the original directory with the certificates copied from the working host.
- Restart the pf9-hostagent and pf9-sidekick service and check if the host is able to communicate with Management Plane by running the below command.
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