Host Fails to Converge With Error: "rpmdb open failed"

Problem

  • A host is failing to converge with the following error printed in /var/log/pf9/hostagent.log.
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Environment

  • Platform9 Managed OpenStack - All Versions
  • Platform9 Managed Kubernetes - All Versions
  • CentOS

Cause

  • One or more partitions on the root disk are full.
  • The Yum database is corrupted on disk.

Resolution

  1. Check the disk utilization on the host.
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  1. If one or more partitions are full, identify where space is being utilized and clear the necessary amount of disk space so that the Platform9 components may continue to function.
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  1. If there is a sufficient amount of disk space available (<97%) on all of the root disk partitions and yum commands fail with the same error, the package database may need to be rebuilt.
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  1. Restart the pf9-hostagent service.
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Additional Information

How to Fix Corrupted Package Database for Yum

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