Host Fails to Converge With Error: "rpmdb open failed"
Problem
- A host is failing to converge with the following error printed in /var/log/pf9/hostagent.log.
Environment
- Platform9 Managed OpenStack - All Versions
- Platform9 Managed Kubernetes - All Versions
- CentOS
Cause
- One or more partitions on the root disk are full.
- The Yum database is corrupted on disk.
Resolution
- Check the disk utilization on the host.
- If one or more partitions are full, identify where space is being utilized and clear the necessary amount of disk space so that the Platform9 components may continue to function.
- If there is a sufficient amount of disk space available (<97%) on all of the root disk partitions and yum commands fail with the same error, the package database may need to be rebuilt.
- Restart the pf9-hostagent service.
Additional Information
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