Host Authorized with Differing/Unexpected Hostname

Problem

  • A host authorized with Platform9 is displaying its name as "localhost", its FQDN is omitted, or it otherwise differs from that of its actual, expected hostname.
  • If the host is authorized with Platform9 Managed OpenStack, instance operations for instances residing on the host may fail with the following error.
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Environment

  • Platform9 Managed OpenStack - All Versions
  • Platform9 Managed Kubernetes - All Versions

Cause

  • The pf9-hostagent service obtains the hostname using the Python function socket.getfqdn().
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  • Verify if the nslookup command is returning the updated hostname. This would indicate that there's no issue with DNS resolution
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  • If nslookup command returns the right hostname, check if there are any old entries associated with the older hostname in the /etc/hosts.

Resolution

Ensure the following:

  1. socket.getfqdn() function returns the expected hostname.
  2. DNS resolution is functional.
  3. For the IPv4 localhost entry in /etc/hosts, the hostname is included as the first entry.
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  1. Restart the pf9-hostagent service.
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Additional Information

If using pf9-express, ensure the Manage Hostname option is set to true during the configuration process to automatically add the hostname entry for localhost on deployment.

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The option may be set directly in pf9-express.conf. file as well.

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