Used Old Installer to Authorize Host "Error Authorizing Host. Please Contact Support

Problem

An attempt to authorize a new host using an installer that was downloaded prior to an upgrade of the Management Plane's current version causes the following error to appear in the Clarity UI: "Error Authorizing Host. Please Contact Support"

Environment

  • Platform9 Managed OpenStack - All Versions

Cause

The installer from the previous version of Platform9 Managed OpenStack on the Management Plane will not contain the correct packages to properly authorize.

Resolution

  1. Deauthorize the host.
  2. Uninstall the existing version of Hostagent.
Copy
  1. Download a fresh installer package from the Clarity UI.
  2. Install the new package on the host and authorize from the UI as normal.
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