Snapshot Image Shows as Missing

Problem

An instance snapshot was taken; however, the image shows as missing in the Platform9 UI.

Environment

  • Platform9 Managed OpenStack - All Versions

Cause

The instance is likely booted from a volume, in which case it's expected that a blank image would be generated.

Resolution

  1. Delete the corresponding image.
  2. Identify the volume snapshot(similar name as the original volume) that was taken. This will be the actual snapshot of the instance since it's booted from a volume.
  3. Create a new volume using the snapshot identified from Step 2.
  4. Upload this newly created volume as an image.

Additional Information

OpenStack Docs - CLI - Volume Snapshot

Type to search, ESC to discard
Type to search, ESC to discard
Type to search, ESC to discard