Hostagent Logs Shows "Cert Update Thread Is Waiting With Timeout of 24 Hours"

Problem

Node doesn't converge to the Platform9 Management Plane. Hostagent logs show entries like below every 24 hours. However, nodes remain in a disconnected state on the PMK GUI.

Hostagent Logs
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Environment

  • Platform9 Managed Kubernetes - v5.6.4 and Higher.

Cause

  • The issue happens due to the node clock is not in sync.
Clock out of sync snippet
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Resolution

  • Sync the node clock using timedatectl and hwclock command followed by pf9-hostagent service restart.
Sync clock using below command
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  • Verify if clock is synced.
Timedatectl
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  • Restart the pf9-hostagent service.
Pf9-hostagent service
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  • Verify if the service is running and the node started converging to the management plane. GUI should show the node as connected.
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