# Docker Image Pull Failed with "Error response from daemon"

## Problem

Docker image pull fails during PMK stack startup with the below error messages:

{% tabs %}
{% tab title="Docker image pull" %}

```bash
[2023-10-31 04:36:16] docker: Error response from daemon: open /var/lib/docker/overlay2/d39acd549d8883feef19a6464c0e1dfe48da0bd1bc83a54aee6e585ba06db8b8/committed: no such file or directory.
```

{% endtab %}
{% endtabs %}

## Environment

* Platform9 Edge Cloud - v-5.3.0-2075501
* Docker client/server - Version: 19.03.11

## Cause

Docker container runtime upstream issue - Ref - [Bug](https://github.com/docker/for-linux/issues/478)

## Resolution

Error indicates that `/var/lib/docker/overlay2` is referencing to some older files which might be cached. So we follow below procedure to fix the issue.

1. Stop the `dockerd` service using below command

{% tabs %}
{% tab title="Docker service" %}

```bash
# systemctl stop dockerd
```

{% endtab %}
{% endtabs %}

2. Move the `/var/lib/docker` directory to `/tmp` and then start the `dockerd` service.

```bash
# systemctl start dockerd
```

## Additional Information

This step will recreated a new **/var/lib/docker** directory and PMK stack should start properly.


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://platform9.com/kb/smcp/solution/docker-image-pull-failed-with-error-response-from-daemon.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
