# Used Old Installer to Authorize Host "Error Authorizing Host. Please Contact Support

## Problem

An attempt to authorize a new host using an installer that was downloaded prior to an upgrade of the Management Plane's current version causes the following error to appear in the Clarity UI: "Error Authorizing Host. Please Contact Support"

## Environment

* Platform9 Managed OpenStack - All Versions

## Cause

The installer from the previous version of Platform9 Managed OpenStack on the Management Plane will not contain the correct packages to properly authorize.

## Resolution

1. [Deauthorize](https://docs.platform9.com/support/how-to-deauthorize-a-host/) the host.
2. Uninstall the existing version of Hostagent.

{% tabs %}
{% tab title="None" %}

```none
# sudo apt-get purge pf9-hostagent
```

{% endtab %}
{% endtabs %}

3. [Download a fresh installer package](https://docs.platform9.com/openstack/infrastructure/add-host/) from the Clarity UI.
4. Install the new package on the host and authorize from the UI as normal.


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://platform9.com/kb/pmo/solution/used-old-installer-to-authorize-host-error-authorizing-host-ple.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
