# VM Build Fails as Network Fails to Get due to Allocated

## Problem

The VM build is failing due to the network not being allocated, although the network agents remain running and in a healthy state.

{% tabs %}
{% tab title="Server show and logs" %}

```bash
//Server show
{u'message': u'Build of instance [VM_UUID] aborted: Failed to allocate the network(s), not rescheduling.', u'code': 500,..raise exception.VirtualInterfaceCreateException()<br>ova.exception.VirtualInterfaceCreateException: Virtual Interface creation failed<br>During handling of the above exception, another exception occurred}

//ostackhost logs
nova.exception.VirtualInterfaceCreateException: Virtual Interface creation failed
eventlet.timeout.Timeout: 300 seconds
```

{% endtab %}
{% endtabs %}

## Environment

* Platform9 Managed OpenStack - v4.0 and Higher

## Cause

The VM creation failed because Nova did not receive the `network-vif-plugged` event within the expected timeout, resulting in a `VirtualInterfaceCreateException`. Although the instance was scheduled successfully and network agents appeared healthy, the event was not delivered to Nova due to a communication issue between Neutron and Nova. As a result, the port binding was never confirmed, and Nova aborted the build with the error *“Failed to allocate the network(s), not rescheduling.”*

This is a known bug and is reported internally with ID: **IAAS-10813.**

## Resolution

The services given below need to be restarted to fix the issue. Ensure all services are up and running. Once services are stable, attempt to build the new instance.

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{% tab title="command" %}

```bash
$ systemctl restart openvswitch
$ systemctl restart pf9-neutron-ovs-agent
$ systemctl restart systemd-machined
```

{% endtab %}
{% endtabs %}

In case this does not help please reach out to the [Platform9 support team ](https://support.platform9.com/hc/en-us)to restart the neutron-server service on the DU.

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{% tab title="command" %}

```bash
$ systemctl restart neutron-server
```

{% endtab %}
{% endtabs %}

## Additional Information

For further questions/concerns regarding the bug, reach out to the [Platform9 Support Team](https://support.platform9.com/hc/en-us)


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