# Worker Node Intermittently Entering Into "Ready, SchedulingDisabled" State

## Problem

One or more Kubernetes nodes are intermittently transitioning into a "Ready, SchedulingDisabled" state, where Kubelet is still heartbeating, but, workloads are no longer able to be scheduled to the node.

## Environment

* Platform9 Managed Kubernetes - All Versions
* Kubelet

## Cause

The node(s) which are impacted are likely facing resource contention/exhaustion - CPU and/or Memory – which prompts scheduling to be disabled for the node by kube-controller-manager, based on the node metrics reported by Kubelet.

## Resolution

1. Ensure that appropriate [pod limits](https://kubernetes.io/docs/concepts/configuration/manage-resources-containers/#resource-requests-and-limits-of-pod-and-container) are set.
2. Ensure that the pod limits set are not excessive, i.e. set too low, which would cause continual pod restarts/evictions, and drive up the resource usage of the node all the same.

## Additional Information

* [Kubernetes Documentation – Managing Resources for Containers](https://kubernetes.io/docs/concepts/configuration/manage-resources-containers)


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://platform9.com/kb/pmk/solutions/worker-node-intermittently-entering-into-ready-schedulingdisabl.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
