Uncordon Node After Maintenance to Make it Schedulable Again
Problem
The Drain node operation being performed on nodes prior to the maintenance of hypervisors results in nodes to be in a Ready, SchedulingDisabled state once the maintenance is completed.
NAME STATUS ROLES AGE VERSION
NodeName Ready,SchedulingDisabled worker 34d v1.12.9The nodes will have NoSchedule taints on them.
Taints: node.kubernetes.io/unreachable:NoSchedule node.kubernetes.io/unschedulable:NoScheduleEnvironment
Platform9 Managed Kubernetes - All Versions
Resolution
Uncordon the nodes to make them schedulable again, thus resuming the procedure of scheduling pods onto it.
# kubectl uncordon [node name]Additional Information
PreviousApplications Failing With Error "504 Gateway Timeout
Nextpf9-kube Fails to Start on Master Node(s)
Last updated
