Unable to Start pf9-kube Service on Master Node
Problem
Unable to start pf9-kube service on the master node
Below errors are reported in /var/log/pf9/pf9-kube/kube.log
docker: Error response from daemon: devmapper: Thin Pool has 6844 free data blocks which is less than minimum required 6859 free data blocks. Create more free space in thin pool or use dm.min_free_space option to change behavior.See 'docker run --help'.Environment
Platform9 Managed Kubernetes - v3.6.0 and higher
Docker
Cause
There are not enough free data blocks on the node. This may be due to dead and/or exited containers still residing on the host.
Resolution
Check the number of containers in dead or exited state.
# docker ps -a -q -f status=dead# docker ps -a -q -f status=exitedRun the below command to clean up any containers matching dead or exited status:
# docker rm $(docker ps -a -f status=exited -q)# docker rm $(docker ps -a -f status=dead -q)Previouspf9-kube Fails to Start on Master Node(s)
NextDocker Container Files or Directories Have 'root:pf9group' (GID: 1001) Permissions
Last updated
