Nodelet Service Fails to Start Causing Convergence Failure as pf9-nodelet Sudoers File is Modified
Problem
Host fails to converge and the nodelet logs shows below error message.
level=info msg="Running command 'sudo /opt/pf9/pf9-kube/setup_env_and_run_script.sh /opt/pf9/pf9-kube/worker_scripts/020-gen_certs.sh name' from wd: ''" func="github.com/platform9/nodelet/pkg/utils/command.(*Pf9Cmd).RunCommandWithStdOut" file="/go/src/github.com/platform9/nodelet/pkg/utils/command/command.go:106"
level=error msg="Error: exit status 1" func="github.com/platform9/nodelet/pkg/utils/command.(*Pf9Cmd).RunCommandWithStdOut" file="/go/src/github.com/platform9/nodelet/pkg/utils/command/command.go:124"Environment
Platform9 Managed Kubernetes - All Versions
Cause
The sudoers file present at location /etc/sudoers.d/pf9-nodelet was overwritten by mistake.
Resolution
Fix the sudo access for pf9-nodelet by copying the /etc/sudoers.d/pf9-nodelet file from a working host.
Restart the pf9-nodeletd service.
~$ sudo systemctl restart pf9-nodeletdPreviousUnable To Onboard Host by Running 'pf9ctl cluster prep-node' Command as 'Download Platform9 installe
NextHost Authorization Failure with Error - Timed Out Waiting For "authn_webhook_listening"
Last updated
