Node Seen in "Error Authorizing Host" State, pf9-kube Service Fails to Start
Problem
Node is seen in "Error Authorizing Host" state in Platform9's Clarity UI.
pf9-kube service on the node fails to start.
Following errors are present in the /var/log/pf9/kube/kube.log on the node.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.Environment
Platform9 Managed Kubernetes - v3.6.0 and Higher
Cause
The packages weren't downloaded/configured correctly when the node was authorized or upgraded. This can also be observed when the same node was deauthorized and re-authorized.
Resolution
Run the following command on the node.
# sudo dpkg --configure -aThen restart the pf9-kube service by running the command.
# /etc/init.d/pf9-kube startThe above command should complete successfully and the prompt should return. Check the status of the pf9-kube service.
PreviousHost Fails to Apply pf9-kube Role With Error "Certificate is Not Yet Valid"
NextError Initializing Docker: "graphdriver: expected integer"
Last updated
