lsb_release Utility Missing Resulting in Node to be in a Failed State
Problem
Node is seen to be in a failed state from the management plane perspective.
abcdefgh-910f-080d-b36b-sf70929bacbc | test.platform9.net | cni0:10.50.92.1 | True | failed | pf9-kube |On the node, the pf9-nodeletd service is in a dead state.
pf9@test:/var/log/pf9$ systemctl status pf9-nodeletd* pf9-nodeletd.service - Platform9 Kubernetes Management Agent Service Loaded: loaded (/lib/systemd/system/pf9-nodeletd.service; disabled; vendor preset: enabled) Active: failed (Result: exit-code) since Thu 2020-12-24 05:16:29 PST; 5 days ago Process: 32556 ExecStart=/bin/bash -c /opt/pf9/nodelet/nodeletd >> /var/log/pf9/nodelet.log 2>&1 (code=exited, status=2) Main PID: 32556 (code=exited, status=2)Environment
Platform9 Managed Kubernetes - All Versions
Cause
Based on the Kube logs from when the service was last active, we can observe that it was failing to run the PMK stack scripts as it could not find the lsb_release utility.
pf9@test:/var/log/pf9/kube$ less kube.logs[2020-12-22 11:52:16] os_ubuntu.sh: line 3: lsb_release: command not found--- /opt/pf9/pf9-kube/worker_scripts/020-gen_certs.sh start at 2020-12-22 11:52:16 ---[2020-12-22 11:52:16] os_ubuntu.sh: line 3: lsb_release: command not found--- status at 2020-12-22 12:01:24 ---[2020-12-22 12:01:24] os_ubuntu.sh: line 3: lsb_release: command not found--- status at 2020-12-22 19:02:57 ---pf9@test:~$ which lsb_release
pf9@test:~$Resolution
Install the missing utility.
Restart the pf9-hostagent service.
Post restart of the pf9-hostagent service, the pf9-nodeletd service should start back up along with the rest of the PMK stack, and the node will then be reported to be in a healthy state to the management plane.
PreviousMultiple Node Attachment for a Cluster Fails Partially if an Offline Node is present
NextKubernetes Resource Quota Not Updating
Last updated
