KubeConfig Download Fails With a Timeout Error
Problem
A timeout error is observed when kubeconfig download is requested from the UI.

The following error is observed in the /var/log/pf9/sidekick.log on the active master node.
Environment
Platform9 Managed Kubernetes - All versions
Cause
When a kubeconfig for a cluster is requested from the UI. kubeconfig generation fails due to a file lock from a previously failed config generation.
Resolution
SSH to the active master node where you see the above error in the sidekick log.
Check for a stale config.lock file under /opt/pf9/home/.kube directory.
Deleted the config.lock file and request a new kubeconfig file.
PreviousError "Communication Failure" During Host Onboarding
NextCoreDNS Configuration Not Re-Generated After Reboot
Last updated
