Error Initializing Docker: "graphdriver: expected integer"
Problem
Docker fails to start with the following error message.
Error starting daemon: error initializing graphdriver: expected integerEnvironment
Platform9 Managed Kubernetes - All Versions
Docker
CentOS
LVM
Cause
The node may have been re-used from a previous Kubernetes cluster for which the Docker volume group (LVM) was not recreated.
Resolution
Warning: The following will erase any data associated with the logical volume(s) contained within the volume group. If you are uncertain about this operation, it may be recommended to perform a backup following the guide provided under the Additional Information section.
Remove any logical volumes associated with the volume group.
Remove the volume group.
Re-create the volume group following the instructions outlined in the Platform9 Managed Kubernetes CentOS prerequisites.
Additional Information
PreviousNode Seen in "Error Authorizing Host" State, pf9-kube Service Fails to Start
NextError Initializing Docker: "devicemapper: Non existing device docker--vg-docker--pool"
Last updated
