BIRD is not ready: Error executing command: read unix @->/var/run/calico/bird.ctl: i/o timeout
Problem
Pod networking is misbehaving.
A description of the
calico-nodepod(s) show thatcalico/node is not ready: BIRD is not ready.
I1205 19:21:04.404697 18222 prober.go:117] Readiness probe for "calico-node-pwbdk_kube-system(efbd1219-5082-4075-8457-d5dcf11420ee):calico-node" failed (failure): calico/node is not ready: BIRD is not ready: Error executing command: read unix @->/var/run/calico/bird.ctl: i/o timeout
I1205 19:21:42.416027 18222 prober.go:117] Readiness probe for "calico-node-pwbdk_kube-system(efbd1219-5082-4075-8457-d5dcf11420ee):calico-node" failed (failure): calico/node is not ready: BIRD is not ready: Error querying BIRD: unable to connect to BIRDv4 socket: dial unix /var/run/calico/bird.ctl: connect: resource temporarily unavailable
I1205 19:22:28.134765 18222 prober.go:117] Liveness probe for "calico-node-pwbdk_kube-system(efbd1219-5082-4075-8457-d5dcf11420ee):calico-node" failed (failure): calico/node is not ready: Felix is not live: liveness probe reporting 503Environment
Platform9 Managed Kubernetes - v5.3 and Higher
Calico- v3.18
IPVS
Felix
Cause
BIRD is consuming an excessive amount of CPU which can lead to timeouts (see: https://github.com/projectcalico/bird/issues/95).
Workaround
List the
calico-nodepods within thekube-systemnamespace.
Identify which pod(s) are affected.
Retrieve the Calico BIRD configuration file from the
calico-nodepod (corresponding to the node which is exhibiting the problem symptom).
Edit the configuration file locally and modify the
scan timefields fromscan time 2;toscan time 10;
Copy the updated BIRD configuration back into the
calico-nodepod.
Reload the BIRD configuration (from within the
calico-node pod).
Attention
Note: The above steps are a temporary workaround and will not be persisted beyond the lifetime of the pod (i.e. the updated configuration will be lost if the pod is killed).
Resolution
A fix has been included in the LTS3 release, which has Calico v3.24 and K8s v1.25. This issue was tracked as part of the jira AIR-1104.
Last updated
